Compatible with Kimai 2.0

Period Insert

Generate entries for a given time period.

Alan Nguyen
Предлагает
Alan Nguyen

This bundle allows you to generate entries for a given time period.

Permissions

This bundle comes with the following permission:

  • period_insert - show the period insert screen to generate entries for a given time period

By default, it is assigned to each user with the role ROLE_SUPER_ADMIN.

Read how to assign these permissions to your user roles in the permission documentation.

Acknowledgements

This plugin is a migration of a bundle created by the software company MR Software GmbH. The plugin now supports Kimai 2.0!

Установка

Копировать файлы

Extract the ZIP file and upload the included directory and all files to your Kimai installation to the new directory:

var/plugins/PeriodInsertBundle/

Or you can clone it directly to the var/plugins/ directory of your Kimai installation:

cd kimai/var/plugins/
git clone https://github.com/lnNgyn1/PeriodInsertBundle.git PeriodInsertBundle

The file structure needs to look like this afterwards:

var/plugins/
├── PeriodInsertBundle
│   ├── PeriodInsertBundle.php
|   └ ... more files and directories follow here ...

Очистить кэш

After uploading the files, Kimai needs to know about the new plugin. It will be found once the cache was re-built. Call these commands from the Kimai directory:

How to reload Kimai cache

bin/console kimai:reload --env=prod

It is not advised, but in case the above command fails you could try:

rm -r var/cache/prod/*

You might have to set file permissions afterwards:

Adjust file permission

You have to allow PHP (your webserver process) to write to var/ and it subdirectories.

Here is an example for Debian/Ubuntu (to be executed inside the Kimai directory):

chown -R :www-data .
chmod -R g+r .
chmod -R g+rw var/

Обновления

Updating the plugin works exactly like the installation:

  • Delete the directory var/plugins/PeriodInsertBundle/
  • Execute all installation steps again:
    • Копировать файлы
    • Очистить кэш

Совместимость

Плагины всегда должны быть совместимы с более высокими версиями Kimai. Следующий список содержит версию плагина и необходимую минимальную версию Kimai.

Версия сборки Минимальная версия Kimai
1.0 - 1.1 2.1.0

Скриншоты

Screenshot
Period insert page to generate timesheet entries
Предлагает

Alan Nguyen

Software developer

Если у вас возникли вопросы, пожалуйста, используйте следующую контактную информацию, чтобы связаться с разработчиком напрямую.
Top